Bank connection trouble, transactions not importing

For the last two weeks, the transactions from one bank are not uploading in my Stessa account. I refreshed the accounts from settings and it shows the actual balance but when I go to transactions it does not show anything. What I can do to fix this? Thanks!


My account shows that I need to “fix it”, but when I do it says it is already connected and does not allow me to enter data or the security code for two-step authentication that I assume it is looking for…what steps are required to fix this? If I delete the account will I lose all of my transactions, and if I re-add it will I have to re-verify all of them / delete duplicates?

Hi I am also having an issue with the “fix it” link. All of my imports are working except for my Chase Credit Card accounts. Those have not worked for 4 months. Do you have any insight? Is your issue resolved? I would appreciate you sharing your experience. Thank you.

1 Like

I’m still having the same issue and nothing has been resolved. My transaction ledger is missing the transactions of one bank. The two bank accounts that are linked to this bank do not show transactions since Oct 10th.

Did you ever get a solution to your problem. I’m having the same issue. It is reflecting the balance but not importing the transactions.

This issue hasn’t been solved yet. This week I was asked to send a screenshot of my transactions from my two bank accounts. I hope they can find what is the problem. I have no transactions since Oct 2019.

William, I just checked my Stessa account tonight and the issue was solved!!! yeiiiii. I got all the transactions that were missing from my transactions ledger in Florida Credit Union. I hope your issue gets solved too!

Thanks to all who have reported various challenges with their bank account links. In general, here are the recommended steps that you can take on your own to get things fixed quickly…

  1. Log in directly to the bank, credit card, or loan account you’re trying to connect.

  2. Make sure your account details are 100% current with the correct phone number, email address, and security questions all answered. Clear any pop-ups or required actions on your part. These are important for establishing solid links to Stessa.

  3. Double-check that you are trying to connect to the most relevant version of your institution in Stessa. If you have a business checking account, sometimes you’ll need to connect to “Acme Bank (Business)” instead of simply “Acme Bank.”

  4. Return to Stessa and try the connection again via the secure bank link.

  5. If you have an existing connection that’s not working as expected, try to “Refresh” by clicking on the small gear icon at far right on your Data Sources page. Select “Refresh” and follow the prompts. Sometimes it can be helpful to do this as a separate step after completing the “Fix It” process.

  6. If you’re still having trouble, log in to Stessa and use the blue circle at lower right to open a private support conversation.

  7. Never post personal banking information or screenshots on this public forum.

I have the same issue. My bank connection seems to connect, refresh and update just fine (show a correct current balance). However, transactions page is not updated. anything tips?

re Bank account imports. Items are going in to different property reports than the one that they are assigned to on the Datasource page.

Looks like an ongoing issue. It’s been 8 days since any of my accounts refreshed. I’ve tried manually refreshing, but no success.

@csudrutai @richbinns @buildinvestmentgroup Thanks for alerting us to the challenges with your bank connections. Each of your situations is likely unique as refresh processes, multi-factor authentication steps, and security protocols vary greatly from one institution to another.

Here are our recommended next steps:

1. Do not delete or remove the connection.
2. Use the “Refresh” option under the small gear icon at far right on your Data Sources page.
3. Repeat the “Refresh” option up to 3 times in order to allow the system to learn your responses.
4. Try again in 48 hours as the source of the problem is often the external bank site (maintenance, technical errors, etc.), which often resolves itself over time.
5. Open a 1:1 support ticket via the blue circle at lower right once you’re logged into Stessa.
6. Be patient with us. Stessa supports connections to thousands of US banks, many of which update their protocols frequently.

Also having an issue with Stessa importing from a Chase account. Was working fine up until towards the end of Feb '20, but since then nothing. Clicking the options to fix it/refresh/edit, all result in “Problem Updating Account”; have been trying for a week or so now, after I noticed it wasn’t updating. Have verified the Chase (Chase for Business) account is accessible and isn’t prompting for any extra auths. Opened a 1:1 about it as well, awaiting a response there.

Thanks in advance.

Hi @pete

You should have gotten a custom link through your email to fix this issue.
Please feel free to message me directly if you can’t find the instruction email or have hard time following the instruction


I use Merchants Bank MN and transactions stopped importing a day ago. I use the fix it link and it takes me back the dashboard and it is still not fixed.

1 Like

i have had no transactions pull in from bank of america for 3 months, dating back to MID MARCH 2020

Transactions only going back a couple of months. One account it is pulling duplicates of every transaction and I have to go in and manually delete every other. Not sure if Stessa will ever fix the issues.

I’m also having issues with my USAA account not refreshing. Hasn’t worked since 23 June 2022 and it’s now August. Stessa support hasn’t been very helpful… No real answers or timeline, just “we’re working on it.” I’m about to switch to a different software program, which is a shame since Stessa has my last 6 months of records… Time to start over.


I’ve been using stressa for a few years. I occasionally get the connection break from USAA but I click fix it and it works. This time I can’t get it fixed. It keeps saying technically issues from USAA try again in 24 hours. I’ve been trying for weeks. In the past it has been an issue with the security questions (not being verified). I don’t know how to fix whatever this issue is. I haven’t had any updates since August.


Hello Devon,
Having “fix it” import issues with Centier Bank.
There is no blue circle at lower right to open a private support conversation - why can’t I see that on my browser when I log in? - I checked every category on the left menu and still no lower right blue circle.