New property address auto-updating to incorrect property

I am trying to add a Property to my Portfolio and when I add the address it enters correctly. Once I add information in and save it, it automatically updates to a different incorrect address. Has anyone else had this issue? Is there a way to fix the problem?

I’ve had a few come up with a weird name, but not entirely incorrect. Either way, you can set a nickname for a property under the Property Details page (Property tab on left > Click on specific property > Click the edit button, looks like pencil in a square next to the address/name in top left).

Yes, I have updated the nickname to be correct. However because the address changes it pulls in the incorrect Zillow data and assessment information which is impacting the numbers. I have tried several times to fix this but it every time it just changes the address in the system. Specifically the address is 308 First St. which I enter. Once that is done it makes it 308 N. First St. which is the wrong address. Very frustrating.

1 Like

Ah, gotcha. For that, you’ll need a Stessa rep (like @devin) to comment. Have not run into the scenario you’re seeing myself.

@robert.robeson We will investigate and get back to you. Our system attempts to find the most perfect address match, but does misfire on rare occasions. Changing the nickname back to the correct address will not alter the back end address in the system, so you’re correct to point out that public records and other data will continue to be inaccurate.

Moving this thread to “Bug Reports” category.

Thanks for looking into it!

@robert.robeson Go ahead and delete the incorrect property via your Properties page, and then try to add the correct one. Wait for the pick list to appear and select the correct address. You should get a better result this time now that we’ve made some adjustments.

I just tried this and it still switched the address. I directly picked the address in the drop down too. Let me know what else I should try. Thanks!

@robert.robeson
Hi Robert, Chris from Stessa engineering here. Sorry for this bug – can I please get the full intended address?

308 First St. Shenandoah, VA 22849

Hi Robert, this bug is now fixed. Thanks for your patience!

I just tried it again and it still switched the property marking. I used the drop down as well. Not sure why it keeps happening.

Any luck on this being corrected?

Just deleted and re-entered and it appears to be working now. Fingers crossed it stays this way. Thanks!

I’m having the same problem as Robert Robeson. I enter the correct address and it is pulling the house next doors address. Has this problem been corrected for everyone or do I need Stessa to correct it. Thanks

@coastal Go ahead and open a one-off support conversation so we can investigate the specific address. If it turns out to be a wider issue, we’ll post a public follow-up note here once resolved.

To open a support convo, just click the blue circle at lower right once you’re logged into Stessa. Then click “New Conversation.”