US Bank will no longer connect

My US Bank connection has dropped again and will no longer connect to stessa. Whenever I push the “Fix it” button and enter my US Bank log in, I get the following message, “Unexpected Error - Your bank or lender returned an unknown error. Please try again in 24 hours.” It has now been two weeks since the last transaction was uploaded. This needs to be fixed or I’ll need to find a more reliable service.


Same here. i’m giving one more week with Stessa, if not I will give my business elsewhere. They say its “our fault” but in reality its Stessa’s fault and whatever company they hired to do the link. This is a waste of my time and they have not fixed this issues in years.

I am having the same issue. My US Bank accounts have not updated in three weeks. It seems like this has always been an issue, but this is the longest I have had to go without being able to re-connect.

I am experiencing same issue with my US Bank account as well. It has been difficult in past as well.

1 Like

Same here. Three weeks since last download. Funny thing is, the last time it connected and downloaded, it actually took 100+ transactions from my personal account (which it is supposed to ignore) and none from my rental account. I had to manually delete all the personal transactions. It has been three weeks since new business-related transactions have downloaded from US Bank.

Guys, can we get this fixed, please?

I’ve tried multiple times in the past past month. This is causing double the work and time compared to just using a simple spreadsheet.

Same here. I’ve been trying everyday with no luck.

Its been over 3 weeks and still not downloading. I Googled problem I think its not in Stessa ability to fix they have an outside company that connects to the banks for them. So they can put in a repair request and then have to wait. And it appears to be a well known problem just seem worst now.
I really like to Stessa but I am also looking at alternatives unfortunately. It took a lot of time to download my stuff and really don’t want to move. But if its not going to work then you really have no choice.

1 Like

Yeah, I have flagged this multiple times as well. They have not added the ability to enter the two factor code that US Bank now requires.