Appfolio PM data source link stuck refreshing

Recently, my Appfolio account for PM in Data Sources is stuck refreshing… can try to edit the credentials, but clicking the button to send code for 2MFA does nothing. It’s just been showing refreshing for several days now, but transactions aren’t coming in. I noticed the PM posted two reports this month, not sure if that’s screwing with it. I can log in manually to the owner portal, so I know it’s activate and password works. Kinda seems like Stessa is stuck waiting for a security code challenge, but there isn’t one (I did that separately through the web page, so it’s not prompting right now).

1 Like

I’m having this same problem, I hope Appfolio is looking into resolving this bug soon.

It may be an issue on Stessa’s side. I think other appfolio accounts are importing fine, though I could be mistaken. Sometimes the 2-factor authentication gets stuck and needs a reset, it seems like.

We had some latency issues over this past weekend, which may have backed up some Appfolio refresh jobs. This should now be resolved. If you’re still seeing a stuck Appfolio connection, please manually refresh your 2FA credentials as this will usually clear the issue and bring in fresh data.

Seems to still be stuck. The data source (PM using Appfolio) wasn’t still refreshing from before, but telling it to refresh seems to just have started the cycle again. Hitting Edit Credentials and then Continue brings up the window prompt for 2FA, but clicking the “Send Code” button doesn’t appear to do anything–not even registering the click. Hitting Cancel closes the window, as expected.

I second this. I am having the same issue. It looks as though some of my data was inputted but all my maintenance from the previous month was not included.

Hey Devin,

How do we manually refresh the 2FA? I tried selecting the refresh account button on the data sources page in the settings drop down menu but that just put the refresh into a continuous loop. I did this today around 10AM and it is still refreshing.

I also tried editing the credentials like you suggested and retyped in my AppFolio password. When it took me to the 2FA pop up, I try to hit the send button to send me a code but the send button doesn’t do anything. The cancel button will close the pop up but the send doesn’t end up sending a code or anything.


1 Like

We’ve now backfilled the fix for the stuck Appfolio refresh issue. It should now be resolved for all users as of Monday afternoon.

After manually refreshing the data source, it did import. Seemed to import and create duplicates of everything, but thankfully it was a small list of transactions.

That’s strange regarding the dupes. If you see that again, please reach out and let us know. The system should check against prior imports and suppress any matching transactions that are already present.

My issue is identical to that of kitakislipsonholding above. My PM just posted some statements yesterday (Wed, 10-Feb) morning, and now Stessa is in a refresh loop. Trying to edit credentials doesn’t fix it, as I’m not able to get it to send a code. Tried w/ both Chrome and MS Edge, same behavior.

And now it did successfully pull in the reports. Not sure if it just took it a long time for the reports to be processed and posted, or if someone did something on the backend.

@pete Yes, we’ve continued to make code improvements in an effort to enhance the stability of these connections. Glad to hear it’s working for you now.

Yeah, agree on the duplicates, same happened to me.

Devin - out of my appfolio properties, there was only one that was negatively impacted by this issue. After a recent refresh, it generated a number of duplicate transactions. I deleted them manually and things look ok. However, upon closer inspection on the data sources tab, I’m seeing two accounts listed under this specific property manager whereas i’m 90-95% sure, there was only one previously so i’m wondering if that’s what led to the duplicates. and if it’s going to continue to pose an issue? The property is a duplex but I don’t recall it having two accounts reflected on the data source page like that previously, but i’m not 100% certain?

For clarity, on the data sources page, under this one property manager, i’m seeing two accounts. They are both named as the address of the property and are identical, except that the first account has a dash before the name. Were there any changes to this functionality that could have caused this?

I’m new to Stessa.
What information do you find useful to sync with AppFolio? What are the benefits.

I currently use Cozy. I know Stessa currently doesn’t support sync with Cozy but I’m not sure why I would want to. :slight_smile:

I am still not able to update from appfolio. I have 2 different PMs using this and i can access them both manually. I click on refresh, 2 stage auth still shows. I try fix it and the window to send me a code just hangs. Can only exit the screen. No code sent.